胖蒜

分享有价值的资源

TePass-1.5.1 版本升级说明

在上个版本发布后,我将自己的网站升级到了PHP8.2,同时给TePass插件也进行了一些兼容性的修复,这次的主要就是对TePass插件进行兼容,从这个版本后,TePass插件可以在PHP5.6,7.0-7.4,8.0-8.2版本下运行,基本兼容了所有的PHP版本。另外一个重要的是因为网站重新备案通过,授权接口变回正常的,上几个版本用到的临时接口可能随时关闭。

TePass-1.5.1 版本

升级内容:

1、去掉上个版本的小程序扫码登陆,因为配置需要小程序客户端,小程序上线又需要备案,太复杂,不实用;
2、修复后台购买会员V免签方式不显示的问题;
3、修复邀请码有效期及显示为时间戳的问题;
4、修复使用payjs引用文件在PHP8.2错误的问题;
5、优化统计页面,修复新用户在后台购买会员,个人中心出现的错误(兼容PHP8.2);
6、兼容所有PHP版本,需要用到SG11扩展的14版本,可以去phpinfo里面看SourceGuardian,见下图:
SourceGuardian
7、因网站重新备案通过,更换到之前的授权接口,上几个版本的临时接口有可能关闭;
8、去掉用户注册页面重复引用的样式文件;
9、优化付款界面二维码显示速度,相较之前的版本有大幅提升;
10、修复之前用户签到出现错误的问题;
11、修复个人中心及积分中心显示错误的问题;
12、优化一些其它地方的代码。

升级操作步骤:

备份现有网站的数据库,禁用现有插件,现有插件文件夹改名备用,再上传新版本插件,解压后启用,测试没问题,再删除旧版本。
特别说明:如何你在启用插件的时候,发现页面是空白的,很大可能性就是SG11版本太低了,这个版本的TePass插件需要SG扩展为14的版本(因为兼容PHP8.2的原因),宝塔面板卸载SG11扩展后重新安装即可,其它的在本站搜索教程更新。更新完SG11扩展后可重启一下PHP,再去启用插件就正常了。

温馨提示:

1、如果你在插件上进行了二次开发,请先备份,启用新版本插件后,再将你二次开发的文件覆盖插件相关文件。
2、再次提醒微信模板消息下架,可转到我的小蒜子来接收提醒:
https://developers.weixin.qq.com/community/develop/doc/000a4e1df800d82acb9b7fb5e5b001?page=1

本文属原创,转载请注明原文:https://pangsuan.com/p/TePass-1-5-1.html

感觉很棒,欢迎点赞 OR 打赏~

分享到:

评论 (0)

立即登录评论
可联系QQ744272645咨询
马上咨询 自媒体号