解决宝塔安装SG11报错 - 胖蒜

解决宝塔安装SG11报错


昨天有人购买插件后,安装SG11扩展出现这个:

SourceGuardian Incompatible loader version. This protected script was encoded with newer version of SourceGuardian. Please download and install the <A HREF="http://www.sourceguardian.com/loaders/">latest loaders</A>. Error code [19] in

SourceGuardian 不兼容的加载程序版本。此受保护的脚本是用更新版本的sourceguardian编码的。请下载并安装最新的加载程序。中的错误代码[19]

宝塔面板自带的版本已经跟不上现在加密的步伐了,于是需要手动更新一下SourceGuardian

更新 /安装 SourceGuardian

浏览器中打开 https://www.sourceguardian.com/loaders/download.php
然后在微擎根目录新建文件名为test.php文件,代码如下;

<?php
    echo phpinfo();
?>

然后把详细网址写到这个框框里,如下图所示;回车然后就会自动判断你的服务器该安装那个版本;
SG11 更新安装界面.png
在线的检查脚本会根据 phpinfo 的信息,提取到 php 版本信息和扩展路径,然后提示你需要的操作。例如它提示我 extension_dir 应设置为绝对路径而非相对路径:
SG11 路劲检测.png
那就改呗,在 php.ini 中找到 extension_dir,将原来的相对路径 ./ext 改为绝对路径。重启 Apache 然后重新执行检测:
SG11更新.png

到这一步它提示我需要:

下载 ixed.5.6.win
安装到 php 扩展的 ext 目录
在 php.ini 中加载它:extension=ixed.5.6.win
重启 Apache
全部修改完成后,在 phpinfo 看到了 SourceGuardian 的相关信息,说明扩展已经生效了:

最后

建议大家使用PHP还是不要运行在win环境,大大小小的坑很多,需要自己踩,确实浪费时间。
另外安装了SG11扩展后,要重启一下PHP,不知道的就重复服务器吧。

转载说明

本文转载自:https://www.zhaiike.com/post-530.html


文章作者: 胖蒜网
版权声明: 本博客所有文章除特別声明外,均采用 CC BY 4.0 许可协议。
您的大名:
万水千山总是情,给个打赏行不行。 打赏
 上一篇
TePass-0.8.0 版本升级说明 TePass-0.8.0 版本升级说明
这个版本主要就是接入了微信的官方支付功能,群里有人要,就加上了,使用微信支付的Native模式,其它模式的后面再说吧,因为我开通不了。
3分钟阅读 本站相关
下一篇 
TePass 接入微信官方H5支付 TePass 接入微信官方H5支付
TePass 这款 Typecho 下的自媒体付费阅读插件,最开始的定位是方便个人开发者收款,加上本人又没有企业,无法开通微信支付,用的是payjs来进行微信收款。
1分钟阅读 本站相关
  目录